Реле, управляемые через интернет

Реле, управляемые через интернет

  • Здравствуйте, уважаемые читатели и гости сайта «Заметки электрика».
  • В прошлых своих публикациях я знакомил Вас с дистанционным выключателем света Сапфир-2503 и сенсорным выключателем Livolo, управляемых, как в ручную, так и с пульта управления.
  • Но сегодня Ваше внимание я хотел бы обратить на реле (переключатель) Sonoff версии Basic с возможностью управления прямо c мобильного телефона через сеть Wi-Fi или Интернет.
  • Реле Sonoff Basic представляет из себя небольшое по габаритам устройство (88х38х23 мм), которое без проблем можно разместить за потолочным пространством, в строительной нише, или чаше люстры или светильника.

Реле, управляемые через интернет

Его стоимость на момент выхода статьи составляет чуть меньше 300 рублей. Как Вы понимаете, это вполне приемлемые деньги, к тому же за такой современный девайс. Приобрел я его на всем известной торговой площадке АлиЭкспресс (ссылочка будет в конце статьи).

Реле, управляемые через интернет

В комплекте прилагались две защитные крышки с крепежными шурупами, а вот инструкции, к сожалению, не было.

Реле Sonoff имеет следующие технические характеристики, часть которых отображена прямо на его корпусе:

  • максимальный ток управляемой нагрузки 10 (А)
  • напряжение питания от 90 (В) до 250 (В)
  • стандарт беспроводной связи 802.11 b/g/n
  • протокол безопасности WPA-PSK/WPA2-PSK
  • температура эксплуатации от 0°С до 40°С
  • масса около 50 г

Реле, управляемые через интернет

Возможности реле Sonoff Basic:

  • управление нагрузкой через Wi-Fi
  • управление нагрузкой через Интернет
  • управление нагрузкой по заданному таймеру, как с прямым, так и с обратным отсчетом
  • управление нагрузкой с нескольких мобильных телефонов

Реле, управляемые через интернет

Вот такие вот возможности имеет реле Sonoff. Его можно смело применять в системах умного дома и для прочих различных нужд и потребностей.

Реле, управляемые через интернет

Сначала я Вам расскажу о том, как подключить Sonoff, а затем проверим все его заявленные способы управления на практике.

Итак, поехали.

Установка и подключение реле Sonoff

Для работы реле Sonoff ему необходимо напряжение питания 220 (В), а значит его без проблем можно установить в удобном для Вас месте, например, в чаше люстры или прямо под натяжным потолком, а также непосредственно в распределительной коробке, если там предостаточно места.

Реле, управляемые через интернет
Реле, управляемые через интернет
Реле, управляемые через интернет

Для крепления реле к поверхности у него имеются два крепежных отверстия.

Реле, управляемые через интернет

Схема подключения реле Sonoff очень простая.

На клеммы (L) и (N) со стороны (Input-Вход) подключается, соответственно, фаза и ноль питающего напряжения 220 (В). Естественно, что при подключении не забываем про цветовую маркировку жил.

Обратите внимание, что подключаемые жилы должны быть сечением не больше 1,5 кв.мм. Но я все же попробовал подключить жилы сечением 2,5 кв.мм. В результате, жесткий (однопроволочный) провод еще можно подключить без проблем, а вот гибкий (многопроволочный) со втулочным наконечником НШВИ уже с большим трудом вставляется в клемму, так что пришлось его даже не много сплющить и деформировать.

Для примера я использовал питающий кабель марки ПВС, который как раз таки имеет сечение 2,5 кв.мм. На другом конце кабеля имеется вилка, которую в дальнейшем я подключу в любую розетку с напряжением 220 (В).

  1. На клеммы (L) и (N) со стороны (Output-Выход) подключается, соответственно, фаза и ноль нагрузки.
  2. Для удобства подключения нагрузки, на выход реле я подключил розетку.
  3. Кстати, клеммные крышки несут не только защитную функцию, но и играют роль зажимов питающих проводов или кабеля.

Вот так получается все красиво и аккуратно. Реле Sonoff подключено.

  • В качестве нагрузки я подключил светодиодную лампу, про устройство которой я подробно рассказывал в одной из своих статей.
  • Вот простенький пример схемы подключения реле Sonoff для группы светильников.

Кстати, в качестве нагрузки не обязательно использовать только лишь лампу или группу ламп. На выходные клеммы можно смело подключать любую другую нагрузку, не превышающую номинальный ток 10 (А). А если Вам все же необходимо управлять нагрузкой, имеющей значение тока выше 10 (А), то ее можно подключить к контактору, а с помощью реле уже управлять катушкой этого контактора.

  1. В связи с этим можно добавить, что при использовании контактором можно управлять, хоть однофазной нагрузкой, хоть трехфазной, хоть переменным током, хоть постоянным.
  2. Будет это выглядеть примерно вот так.

Таким образом, сфера применения реле Sonoff очень широкая и разнообразная. Им можно управлять, хоть одной лампочкой, хоть мощным однофазным электронагревателем, хоть трехфазным электродвигателем и т.д. Все зависит только от Ваших нужд и потребностей.

А теперь рассмотрим все возможности управления реле Sonoff более подробнее.

Вскрывать реле и смотреть его устройство я не буду, на этот счет уже предостаточно информации в Интернете — посмотрите соответствующие ресурсы по электронике. И судя по отзывам, исполнение у реле вполне достойное. Кстати, кому интересно знать, то реле собрано на базе известного китайского микроконтроллера ESP8266.

Управление нагрузкой через телефон по сети Wi-Fi

Прежде чем рассказать про управление реле через Wi-Fi, скажу, что им можно управлять и в ручную. Для этого на его корпусе имеется небольшая утопленная кнопочка черного цвета.

Так вот при одном кратковременном ее нажатии реле включается, а при повторном нажатии, соответственно, отключается.

Причем для этого не обязательно, чтобы реле было подключено к сети Wi-Fi — управление будет осуществлять и в Offline режиме.

Но помимо этого кнопочка несет в себе и другой функционал, о котором я расскажу чуть ниже.

Для реализации возможности управления нагрузкой через Wi-Fi и Интернет необходимо установить на телефон мобильное приложение eWeLink. Это приложение можно найти, как для устройств с Android, так и с iOS. Для облегчения поиска приложения можно воспользоваться необходимыми QR-кодами на упаковке.

Управление через интернет

В этом небольшом обзоре рассмотрим четыре вида реле, управляемых через интернет, от российской компании KERNELCHIP.

Данное предприятие на протяжении более чем 10 лет профессионально занимается разработкой и программированием нестандартных устройств сопряжения с компьютерами, а также разработкой систем автоматизации и управления и систем удаленного управления и мониторинга по сети Ethernet и по GSM/GPRS. Сегодня, когда интернет есть повсюду, такие решения актуальны как никогда. Речь пойдет об управляемых реле серии Лоран (Laurent).

Laurent-T

Реле, управляемые через интернет

Данный модуль имеет особенность — специальное назначение: сбор и передача, посредством Ethernet (LAN) интерфейса, показаний цифровых термодатчиков. Модуль способен работать максимум — с 20 датчиками типа Dallas DS18B20. Датчики подключаются к общей шине 1-Wire.

Таким образом, Laurent-T представляет собой Ethernet – контроллер температуры, способный работать с от 1 до 20 датчиками, имеющий встроенный веб-интерфейс с удобной таблицей имен датчиков (которые пользователь может произвольно задавать), с возможностью аппаратного сброса шины 1-Wire при помощи встроенного реле, при этом командный интерфейс (API), конечно, открытый.

Часто на предприятии возникает надобность в групповом сборе данных с цифровых датчиков температуры — в централизованном сборе показаний. Это удобно делать через сеть Ethernet удаленно. Не всегда ведь есть время ходить и собирать по крупицам информацию от каждого из десятков цифровых термодатчиков, подключенных через 1-Wire шину. Вот такие задачи и помогает решать модуль Laurent-T.

Реле, управляемые через интернет

Собранные с датчиков показания будут переданы оператору по Ethernet-сети через интегрированный веб-интерфейс, XML/JSON или командную строку (TCP порт). Каждому датчику может быть легко назначено имя в соответствии с идентификационным номером датчика.

Показания с датчиков защищены от кратковременных помех (свойственных для длинной линии) посредством сглаживания и фильтрации. В случае неполадок на шине, происходит автоматический сброс с помощью реле.

Таким образом, большое количество датчиков температуры может отслеживаться и контролироваться в удаленном режиме.

Реле, управляемые через интернет

Встроенная веб-страница открывается в любом браузере, стоит только ввести IP адрес модуля, который по умолчанию имеет значение 192.168.1.99, и пользователь увидит удобный наглядный интерфейс для наблюдения показаний со всех датчиков температуры в режиме реального времени. Таблица имен датчиков будет храниться в энергонезависимой памяти модуля.

Laurent-112

Реле, управляемые через интернет

Модуль Laurent-112 построен на базе 12 реле для управления различными устройствами через Ethernet посредством веб-интерфейса или с помощью открытого командного интерфейса.

На плате имеется 12 реле, рассчитанных на коммутацию напряжения от 0 до 220 вольт, при токе до 7 ампер. Каждым реле можно управлять отдельно.

Система CAT позволяет реализовать управляемую реакцию на события: по таймеру или, например, при отсутствии ответа удаленного сетевого устройства по команде PING. Командный интерфейс (API) здесь открытый.

Реле, управляемые через интернет

Встроенная веб-старница для управления модулем откроется в любом браузере, достаточно только ввести IP-адрес модуля, который по умолчанию имеет значение 192.168.0.101.

Интерфейс удобно визуализирован, состояния реле видно (кнопка включена — зеленая или кнопка выключена — серая). Интегрированный веб-интерфейс по желанию может быть защищен паролем, который можно изменять.

В комплект поставки изделия входит только сам модуль, источник питания приобретается отдельно.

Laurent-2

Реле, управляемые через интернет

Это модуль с расширенным функционалом, он отличается богатой аппаратной периферией для управления реле и для мониторинга и настройки параметров различных устройств по сети.

Допускается автономная обработка событий (счетчики импульсов, таймер, PING, АЦП, датчик температуры). Модули могут взаимодействовать между собой при помощи специальных команд (см.

инструкцию) даже без участия сервера (функция M2M).

Плата оснащена 4 реле на максимальный ток до 7А.

Имеет на себе 4 счетчика импульсов, 6 дискретных входов, 12 дискретных выходов, выход ШИМ, RS-232, пару АЦП 10 бит, вход для цифрового датчика температуры KTS-18B20, систему CAT – управляемая реакция на события, открытый командный интерфейс (API). Таким образом данный модуль — это улучшенная и развитая модель предыдущих изделий с полным сохранением совместимости разъемов и команд.

Модуль Laurent-2 подходит для управления аналоговыми и цифровыми устройствами, исполнительными механизмами и датчиками по Ethernet. Способы управления модулем возможны различные: по веб-интерфейсу, при помощи прямых http-запросов, текстовыми командами через TCP порт, посредством данных поступающих от COM порта, автономно по системе CAT, наконец путем M2M.

Реле, управляемые через интернет

Встроенная в модуль веб-страница управления заработает в любом браузере, ее адрес по умолчанию 192.168.0.101. Здесь удобный визуализированный интерфейс для управления различными ресурсами модуля и для мониторинга его параметров в режиме онлайн.

Реле, управляемые через интернет

С помощью системы CAT настраиваются реакции модуля на различные события на его входах: по превышении температурного порога, по счетчику импульсов, по таймеру или при отсутствии ответа от удаленного устройства на команду PING. Система CAT позволяет запрограммировать модуль и использовать его даже автономно без необходимости быть все время подключенным к сети.

Читайте также:  Как узнать мощность светодиодной ленты

С помощью модуля Laurent-2 и системы CAT можно быстро построить систему автоматического мониторинга состояния сервера по сети и сразу перезагружать его, в случае обнаружения «зависания».

Сервер и Laurent-2 станут находиться в одной подсети.

Laurent-2 на периодической основе будет посылать команду PING серверу по его IP, и если не будет ответа — воспроизведется автоматический сброс питания через реле.

Модули Laurent-2 могут быть с легкостью подключены к беспроводной Wi-Fi сети через Wi-Fi роутер. Такая комбинация модуля Laurent-2 и Wi-Fi роутера позволяет контролировать / управлять модулем практически с любого устройства оборудованного Wi-Fi интерфейсом на значительном расстоянии.

Laurent-2G

Модуль Laurent-2G — модифицированная версия модуля Laurent-2, просто добавлен GSM-модем с возможностью подключить к нему антенну.

Laurent-2G, как и предыдущая модель, предназначен для управления цифровыми и аналоговыми устройствами, датчиками и исполнительными механизмами через Ethernet (LAN) интерфейс, только здесь еще появилась возможность управления через GSM интерфейс — с помощью SMS-команд или тоновых команд DTMF.

Андрей Повный

Рис.2. Модуль WIZ812MJ

Программа для Ардуино#include #include #include #include #include #define ONE_WIRE_BUS 6OneWire oneWire(ONE_WIRE_BUS); //Настройка 1wire для работы с 6-м выводом АрдуиноDallasTemperature sensors(&oneWire); //Подключаем датчик температурыint ii=1;int ij=0;byte r=0,g=0,b=0;char buf;char bb;// assign a MAC address for the ethernet controller.// fill in your address here:byte mac = {0x0E, 0xAD, 0xBE, 0xEF, 0xFE, 0xED};// fill in an available IP address on your network here,// for manual configuration:IPAddress ip(192,168,1,30);// fill in your Domain Name Server address here:IPAddress myDns(8,8,8,8);IPAddress gateway(192,168,1,1);IPAddress subnet(255,255,255,0);// initialize the library instance:EthernetClient client;int ia=0,ja=0;int addr = 0;char server;int buttonState = 1;unsigned long lastConnectionTime = 0; // last time you connected to the server, in millisecondsboolean lastConnected = false; // state of the connection last time through the main loopconst unsigned long postingInterval = 14*1000; // delay between updates, in millisecondsint freeRam () {extern int __heap_start, *__brkval;int v;return (int) &v — (__brkval == 0 ? (int) &__heap_start : (int) __brkval);}void setup() {pinMode(3, OUTPUT); // LED 1pinMode(4, INPUT); // Кнопка PD4pinMode(5, OUTPUT); // LED 2pinMode(7, OUTPUT); // LED 3// start serial port:Serial.begin(9600);// give the ethernet module time to boot up:delay(1000);buttonState = digitalRead(4);// Проверка, нажата ли кнопка PD4 сразу после включения питанияif (buttonState == 0){ // Если нажата, необходимо ввести имя промежуточного сервераfor(ia=0;ia

Управляемое реле через интернет купить в Москве недорого | Реле управляемое по Ethernet

При использовании различной бытовой техники и производственного оборудования нередко оказывается полезной возможность дистанционного управления их работой. С такой задачей с лёгкостью справится предлагаемое реле. Этот прибор способен управлять электрооборудованием по сигналам, получаемым из сети интернет.

В конструкции описываемого реле применены решения, составляющие современные достижения IT технологий. Устройство представляет собой коммутатор электрической нагрузки, управляемый по Ethernet.

Реле размещено в компактном корпусе, изготовленном из пластика повышенной прочности. Для подключения внешних цепей и удобства визуального контроля на наружной части корпуса расположены:

  • контакты для подключения проводов напряжения питания;
  • разъём для осуществления связи с сетью Ethernet;
  • индикатор «Status», свечение которого сигнализирует о том, что модуль находится в работе;
  • индикаторные светодиоды, отображающие режимы работы выходных релейных каналов;
  • клеммы для подключения выходных цепей.

Оптимальное напряжение питания управляемого реле — 12 вольт. В комплекте поставки — блок питания реле 12 в 500 мА. Входное напряжение блока питания реле — 220 в.

Контакты исполнительных реле рассчитаны на ток нагрузки до 7 ампер при напряжении 250 вольт. Для коммутации более мощной нагрузки, в том числе трёхфазной, управляемое реле дополняется контактором требуемой мощности.

Реле, управляемые через интернет

Наличие: 196 шт.

Устройство сертифицировано СЕРТИФИКАТ   IP-реле RODOS-8 – это идеальное решение для управления электрической нагрузкой через интернет, если Вы ищете простое и надежное устройство для реализации Ваших идей. Управление нагрузкой: одно встроенное эле..

2 950 руб

ID Товара: 136

Реле, управляемые через интернет

Наличие: 54 шт.

Устройство сертифицировано СЕРТИФИКАТ   IP реле RODOS-8 DIN – компактный коммутатор нагрузок в универсальном корпусе, который без проблем можно установить на DIN рейку либо прикрепить к стене, используя специальные крепления.   ..

2 900 руб

ID Товара: 188

Реле, управляемые через интернет

Наличие: 52 шт.

IP реле RODOS-12 DIN – коммутатор нагрузок на 8 выходов с сухими контактами. Корпус устройства позволяет крепить устройство на стену, используя специальные крепления, либо устанавливать его на DIN рейку.   Управление нагрузкой: 8 встр..

5 600 руб

ID Товара: 217

Реле, управляемые через интернет

Наличие: 3 шт.

Интернет реле RODOS-8 Open Frame – специальная версия одноканального коммутатора нагрузок в сверхкомпактном исполнении без корупуса для установки в модульных системах автоматизации. Предусмотрена установка устройства на DIN рейку, а также на вертикальные стойки с рез..

2 400 руб

ID Товара: 202

Реле, управляемые через интернет

Хит продаж

Наличие: 119 шт.

Устройство сертифицировано СЕРТИФИКАТ   Интернет реле RODOS-9 – многофункциональный коммутатор питания в прочном пластиковом корпусе. Встроенный web-интерфейс позволяет управлять питанием подключенных приборов с  компьютера либо смартфона ..

3 350 руб

ID Товара: 137

Реле, управляемые через интернет

Скидка

Наличие: 96 шт.

Устройство сертифицировано СЕРТИФИКАТ Ethernet реле RODOS-10 – надежное, поверенное временем устройство для управления питанием различных приборов. Принимая определенные команды RODOS-10 коммутирует электрические линии через встроенные реле, тем самым позволяя включать и выключать подклю..

3 550 руб 3 350 руб

ID Товара: 138

Реле, управляемые через интернет

Наличие: 4 шт.

Устройство сертифицировано СЕРТИФИКАТ Ethernet реле RODOS-18 DIN – релейный коммутатор питания для электроприборов. В конструктиве устройства используются только надежные компоненты и решения, проверенные временем. Качественный удобный корпус позволяет устанавливать RODOS-18 на..

9 500 руб

ID Товара: 179

Хит продаж

Наличие: 37 шт.

Устройство сертифицировано СЕРТИФИКАТ Ethernet реле RODOS-10N DIN – современное качественное решение для коммутации питания электроприборов. Мы поставляем RODOS-10N DIN без посредников напрямую от производителя, что позволяет нам предлагать Вам продукцию высочайшего качества по прие..

3 550 руб

ID Товара: 186

Интернет реле RODOS-10 Open Frame — компактное и одновременно мощное устройство для коммутации питания различных приборов, выполеннное в универсальном исполнении, позволяющем встраивать его в модульные системы автоматизации либо устанавливать отдельно на DIN рейку или вертикальные с..

2 900 руб

ID Товара: 203

Особенностью данного реле является возможность его подключения к сети интернет благодаря наличию Web интерфейса и фиксированного IP адреса. Для входа в интерфейс реле достаточно ввести его IP адрес в браузере. После этого работой устройства можно управлять дистанционно.

Сам процесс управления может быть как ручным, так и автоматизированным с использованием программных алгоритмов. Это обеспечивается возможностью реле принимать команды в формате UDP. Благодаря этому важному свойству, управляемые реле могут быть интегрированы в различные автоматизированные системы.

Области применения

Управляемые посредством команд из интернета реле могут иметь самый широкий спектр применения, как в быту, так и в целях контроля и управления производственными технологическими процессами. Отдельными примерами использования этих приборов могут служить:

  • регулирование работы отопительных систем — электрических, путём коммутации электрообогрева, водяных, с управлением электроприводами кранов и задвижек;
  • автоматизация систем вентиляции и кондиционирования;
  • удалённый контроль различного технологического оборудования.

Для удобства монтажа предусмотрены исполнения моделей с установкой на din рейку либо с помощью крепёжных ушек на плоскую поверхность. Существуют модификации с различным числом независимых каналов управления — 1, 4 или 16.

Преимущества заказа управляемого реле в нашем магазине

Наша компания тесно сотрудничает с разработчиком прибора, у которого Вы можете получить бесплатную консультацию на нашем сайте.

Покупая у нас, Вы получаете отечественный продукт с гарантией производителя.

WiFi реле

Реле, управляемые через интернет World On RF World On

  • WiFi реле для управления любым электроприбором, розеткой или выключателем со смартфона через интернет.
  • Работает online или по расписанию (поддерживает до 8 таймеров).
  • Функциональное русскоязычное приложение Ewelink для IOS и Android позволит вам легко управлять всеми функциями устройства

World On Реле, управляемые через интернет Водонепроницаемый чехол Sonoff IP66 World On RF

  1. WiFi реле для управления любым электроприбором, розеткой или выключателем со смартфона через интернет или с помощью пульта (частота 433МГц).
  2. Включатеся/выключатеся online, по расписанию (поддерживает до 8 таймеров) или с пульта (1 пульт идет в комплекте).
  3. Функциональное русскоязычное приложение Ewelink для IOS и Android позволит вам легко управлять всеми функциями устройства

World On RF Реле, управляемые через интернет World On TH Водонепроницаемый чехол Sonoff IP66

  • Sonoff IP66 — это высококачественный водонепроницаемый корпус, который можно использовать с Sonoff World On и World On RF в подводной среде.
  • Водостойкий уровень водонепроницаемой коробки — IP66.
  • Это позволяет вам дистанционно управлять светом или бытовой техникой на открытом воздухе.

Водонепроницаемый чехол Sonoff IP66 Реле, управляемые через интернет World On Dual World On TH

WiFi реле с датчиками температуры и влажности для управления любым электроприбором, розеткой или выключателем со смартфона через Интернет.

Работает Online: вы видите температуру и влажность на экране смартфона и можете Включить/Выключить устройство; по расписанию (макс. 8 таймеров); по датчику температуры или влажности — устройство автоматически Включается/Выключается по достижению заданных параметров.

Функциональное русскоязычное приложение Ewelink для IOS и Android позволит вам легко управлять всеми функциями устройства

World On Dual Реле, управляемые через интернет World On 4CH World On POW

WiFi реле для управления любыми электроприборами через интернет с функцией статистики использования электроэнергии. Управляйте энергопотреблением в режиме онлайн или получайте данные о мощности, силе тока в виде отчетов за определенный период.

Анализируя данные от SonoFF POW вы сможете существенно сэкономить на оплате за электроэнергию! Работает online или по расписанию (поддерживает до 8 таймеров).

Функциональное русскоязычное приложение Ewelink для IOS и Android позволит вам легко управлять всеми функциями устройства

World On POW Реле, управляемые через интернет World On 4CH PRO World On 4CH

  1. Дистанционное включение / выключение электрических приборов из любой точки мира
  2. Возможность подключения четырех приборов к одному реле
  3. Одновременное управление четырьмя каналами реле
  4. Отлично подходит для промышленного использования
  5. Статус всех четырех каналов в реальном времени
  6. Таймеры по расписанию и обратному отсчету для включения / выключения в указанное время
  7. Включение / выключение группы устройств одним нажатием

World On 4CH World On 4CH PRO

  • Четырехканальное реле с дополнительной возможностью управления пультом
  • Поочередное управление четырьмя каналами
  • Отлично подходит для установки на DIN-рейку
  • Статус всех каналов в реальном времени
  • Таймеры по расписанию и обратному отсчету для включения / выключения в указанное время
  • Включение / выключение группы устройств одним нажатием
Читайте также:  Теплый пол в загородном доме

МощностьWorld On

Техника 10 A 16 A
Стиральная машина
Утюг
Телевизор
Микроволновка
Холодильник
Котел

* Мощность электроприбора, который Вы подключаете, указана в его техническом паспорте или руководстве по эксплуатации

Возможности SonoFF World On

  • Online статус устройства и Включение/Выключение со смартфона через Интернет
  • Включение/Выключение по установленному таймеру (до 8 таймеров)
  • Управление неограниченным количеством устройств с одного смартфона (удобное управление группами устройств)
  • Русскоязычное приложение для IOS и Android
  • Установите в розетку и подключите к любому электроприбору
  • Настройте подключение к сети Интернет
  • Управляйте Миром со смартфона

Технические характеристики

Максимальная мощность 2200 Вт
Максимальная сила тока 10А / 16А
Входное напряжение 90-250В Частота (50-60Гц)
Рабочие температуры -20°C — +65°C(только для использования внутри помещения)
Частота WiFi 2.4 ГГЦ
Влажность 5%-95%
Цвет Белый
Размер ДхШхВ

MP3506 — Интернет-реле 2 канала купить в Мастер Кит. Драйвер, программы, схема, отзывы, инструкция, своими руками, DIY

  • MP3506 — Интернет-реле 2 канала купить в Мастер Кит. Драйвер, программы, схема, отзывы, инструкция, своими руками, DIY
  • MP3506 — Интернет-реле 2 канала купить в Мастер Кит. Драйвер, программы, схема, отзывы, инструкция, своими руками, DIY
  • У нас Вы можете купить Мастер Кит MP3506 — Интернет-реле 2 канала: цена, фото, DIY, своими руками, технические характеристики и комплектация, отзывы, обзор, инструкция, драйвер, программы, схема
  • Мастер Кит, MP3506, Интернет-реле 2 канала, цена, описание, фото, купить, DIY, своими руками, отзывы, обзор, инструкция, доставка, драйвер, программы, схема
  • https://masterkit.ru/shop/1922598

Готовый модуль Реле, управляемые через интернет Реле, управляемые через интернет Реле, управляемые через интернет

2 460

о поступлении на склад

Напряжение питания (В) 12
Тип питания постоянный
Длина (мм) 70
Ширина (мм) 40
Высота (мм) 20
Вес, не более (г) 50
Потребляемый ток, не более (мА) 450
Максимально допустимый ток нагрузки (А) 10
Количество встроенных реле управления (шт) 2
Вес 70

Инструкции

Реле, управляемые через интернет

Схема

Реле, управляемые через интернет

Схема

Комплект поставки

  • Модуль МР3504 — 1 шт.
  • Инструкция — 1 шт.

Подготовка к эксплуатации

  • Для настройки модуля в работу необходимо выполнить следующие действия
  • Настроить модуль на подключение по WiFi к вашей локальной сети. Программу настройки — Конфигуратор ESP_STA_Config можно взять на закладке Скачать. Доступны версии для Windows и Андроид. Инструкция по настройке там же.
  • Установить на Андроид устройство приложение mqtt_2rele.apk Закладка скачать

Техническое обслуживание

  • Внимание! Вход в режим настроек приводит настройки модуля к заводским значениям. Восстанавливается пароль по умолчанию для точки доступа 180160180160. Этим можно пользоваться, если вы забыли сетевые настройки или поменяли роутер домашней сети.
  • Работа большого количества других WiFi сетей в зоне настройки модуля может мешать и увеличивать время отклика модуля на ваши команды. Желательно настроить вручную свой роутер на наименее загруженный эфирный канал.

Вопросы и ответы

  • ВНИМАНИЕ !!!
    • Важная информация для пользователей модулями MP3506, MP3509 MQTT Бесплатный брокер iot.eclipse.org сменил название теперь он называется mqtt.eclipse.org Для возобновления работы модулей необходимо поменять название в программе для Андроид и в плате MP3506, MP3509_MQTT, или использовать другой подобный бесплатный сервис.
  • Добрый день! Будьте добры, на производстве стоит задача: ость откатные ворота с радио модулем. Также от двигателя — в офис проложен информационный провод с кнопкой (для открытия ворот кнопкой из офиса) Однако ввиду работы — сотрудники постоянно шлангуются по производству и в офисе не всегда. Однако WIFI есть по периметру всего производства. Возможно ли установить данное реле вместе кнопки на этот информационный провод? И открывать ворота через WIFI. Открытие/Закрытие происходить путем короткого замыкания двух проводов (а не принципом замыкания двух проводов как на реле?) И второй вопрос: будет ли возможность поставить программу открытия ворот на смартфоны сотрудников, чтобы они могли нажимать только кнопку (а не писать комманду — открытия/закрытия) — пол офиса — БЛОНДИНКИ)) Заранее спасибо!!!
    • 🙂 Подождите пожалуйста некоторое время, в продажу поступит модуль MP3509. Он подойдет для решения вашей задачи. Можно было бы сейчас использовать модуль MP3500, но есть особенность работы реле в момент запуска. После отключения питания и подачи его вновь, ворота могут открыться

Управление интернет-реле из RouterOS Mikrotik через API

Реле, управляемые через интернет

Удобный инструмент для управления PDU в роутерах MikroTik

Компания MikroTik известна как производитель сетевого оборудования, отличающегося высокой надежностью при низкой цене и богатой функциональности. Программной основой для продуктов MikroTik является RouterOS – сетевая операционная система на базе Linux.

Она запускается на RouterBOARD – большой линейке аппаратных решений, которая включает в себя как чисто операторское оборудование, так и платформы для домашнего использования.

RouterOS предоставляет администратору/пользователю большие возможности настройки и управления маршрутизатором, позволяя оперировать не только встроенным функционалом системы, но и создавать свои варианты практически любых решений, через скрипт-программирование.

В данной статье я рассмотрю как можно использовать расширенный функционал роутеров MikroTik для подачи команд управления электропитанием при помощи PDU (интернет-реле) непосредственно с роутера через функции-скрипты. В качестве PDU я использовал Ethernet-реле RODOS-8/9/10 фирмы «ОЛИМП» (устройства абсолютно идентичны в плане управления), которые остались после нескольких проектов и были «под рукой».

Возможности RouterOS для управления PDU

Расширенный функционал RouterOS может позволить:

  • Удаленно включать/выключать питание подключенных к PDU устройств
  • Удаленно управлять PDU по наступлению различных событий в сети (скажем, при отсутствии ответа от какого-либо устройства на ping, при подключении к роутеру определенного VPN-клиента, клиента wifi-сети и.т.д…), в зависимости от времени (по расписанию)
  • Производить оповещение администратора или пользователей об изменении состояния реле на PDU на электронную почту или номер телефона (по SMS)

Таким образом, можно организовать, например, управление оборудованием серверной, включать/выключать/перезагружать «зависшее» сетевое оборудование, включать охлаждение или обогрев, освещение, управлять любыми допустимыми по номинальной мощности нагрузками в составе «Умного дома» и многое другое, что сможет позволить Ваше воображение.

Возможность управлять интернет-реле из RouterOS предоставляет команда роутера fetch, синтаксис которой подробно описан по ссылке в конце статьи.

Управление PDU через команду роутера «fetch»

PDU RODOS-8/9/10 поддерживают следующий формат URL-обращений: http://[логин]:[Пароль]@[IP адрес][/protect]/rb[X-1][action].cgi

  • Логин и пароль – соответствующие данные для доступа к устройству в «защищенном режиме» (protect)
  • IP-адрес – IP адрес устройства в сети
  • /protect – ключ доступа в «защищенном режиме». Если на устройстве установлен «открытый» доступ, /protect не указывается, также не указывается логин и пароль
  • [action] – совершаемое действие над реле: n-включить, f-выключить, s-выдать импульс длительностью 1 сек
  • X – номер реле, к которому происходит обращение, возможные значения зависят от модели устройства:
    1. RODOS-8 – не указывается, т.к. устройство имеет единственное реле
    2. RODOS-9 – X=1 или X=2
    3. RODOS-10 – X=[1-4]

Все указанные параметры передаются без скобок []. Таким образом, для решения нашей задачи в RouterOS, чтобы включить первое реле нашего PDU, достаточно следующей записи: /tool fetch url=»http://[логин:пароль]@192.168.1.20/protect/rb0n» Если мы хотим, чтобы от устройства вернулся ответ, следует использовать: /tool fetch url=»http://[логин:пароль]@192.168.1.20/protect/rb0n» mode=http dst-path=»Rodosanswer.txt»; :local Rodosanswer [/file get Rodosanswer.txt contents]; Ответ PDU в нашем случае возвращается с помощью механизма json в переменную Rodosanswer в следующем виде:

  • «Success! » – в случае успешного выполнения команды
  • «Fault» – при невыполнении команды (как правило, при обращении без указания в URL-строке логина и пароля PDU, если PDU находится в «защищенном» режиме)

Создаем функцию управления PDU Rodos в репозитории роутера Мikrotik

Итак, приступим. Создадим функцию управлением реле на примере управления RODOS-10 в реппозитории скриптов роутера MikroTik под именем «Func_RODOS10rele»: Код «Func_RODOS10rele»################ FuncRODOS10rele ######################
# Функция установки состояния реле PDU RODOS-10
# by Sergej Serkov 23.12.

2017
#######################################################

# определяем функцию, устанавливающую реле
:global FuncRODOS10rele do={
:local Sport «»;
:if ([:len $Rport]=0) do={:set Sport «80»;} else={:set Sport $Rport;}
:global FuncPing; :local PingAnswer [$FuncPing PingAdr=$Radr];
:if ($PingAnswer=»OK») do={
:local Rprotect; :local Wprotect; :local Rmode «0»; :local Nrele 0; :local Act;
:if (([:len $Rlogin]=0) and ([:len $Rpass]=0)) do={:set Rprotect «»; set Wprotect «»;} else={:set Rprotect («$Rlogin».»:».»$Rpass».»@»); set Wprotect «/protect»;}
:if ($Rstatus=»on») do={:set Rmode «1»; :set Act «n»}
:if ($Rstatus=»off») do={:set Rmode «1»; :set Act «f»}
:if ($Rstatus=»inv») do={:set Rmode «1»; :set Act «s»} else={}
:if ($Rmode=»1″) do={
:set Nrele ([:tonum $Rrele] — 1);
:if (($Nrele > -1 and ($Nrele < 4)) do={ :local StrFetchRodos; :set StrFetchRodos ("http://"."$Rprotect"."$Radr".":"."$Sport"."$Wprotect"."/rb"."$Nrele"."$Act".".cgi"); do { [/tool fetch url=$StrFetchRodos mode=http dst-path="Rodosanswer.txt";]; } on-error={: log info ""; :log error ("Call ERROR function ERROR fetch command"); :local Rodosanswer "ERROR: command ROS "; : log info ""; :return $Rodosanswer} :log info ""; :log warning ("Сall "."$Wprotect "."function set rele #"."$Rrele "."is ["."$Rstatus"."]"); :log info ""; :delay 2s; :local Rodosanswer [/file get Rodosanswer.txt contents]; /file remove Rodosanswer.txt; :return $Rodosanswer; } else={ :log info ""; :log error ("Сall ERROR"."$Wprotect "."function set rele#"."$Rrele"." but NUMBER RELE MISMATCH"); :log info ""; :local Rodosanswer "ERROR: rele range mismath"; :return $Rodosanswer;} } else={ :log info ""; :log error ("Сall ERROR"."$Wprotect "."function set rele#"."$Rrele"." but RELE REGIME SET MISMATCH"); :log info ""; :local Rodosanswer "ERROR: rele regime set mismatch"; :return $Rodosanswer;} } else={ :log info ""; :log error ("Сall ERROR"."$Wprotect "."function but DEVICE NOT RESPONDED"); :log info ""; :local Rodosanswer "ERROR: device not responded"; :return $Rodosanswer;} } Функция FuncRODOS10rele также использует в своей работе другую небольшую функцию проверки сетевого адреса на ping – FuncPing, которая должна присутствовать в окружении переменных реппозитория роутера при работе основной функции. Код «Func_Ping»:global FuncPing do={
:local PingCount 3; # количество пингов;
:local Result [/ping $PingAdr count=$PingCount];
:delay 2s;
:local PingAnswer «»;
:local MainIfInetOk false;
:set MainIfInetOk ((3*$Result) >= (2 * $PingCount))
:put «MainIfInetOk=$MainIfInetOk»
if (!$MainIfInetOk) do={
:set PingAnswer «ERROR»
}
if ($MainIfInetOk) do={
:set PingAnswer «OK»
}
:return $PingAnswer;}

Применение функции управления реле

В качестве параметров функции FuncRODOS10rele нужно передавать следующее:

  • Radr – IP-адрес устройства
  • Rport — http порт. Если настроен стандартный порт для http (80) этот параметр можно не указывать
  • Rrele — номер реле над которым производим действие (для RODOS-10 [1-4]), для RODOS-9 [1-2], для RODOS-8 не передается)
  • Rstatus — совершаемое действие («off»-выключить; «on»-включить; «inv» — выдать импульс)
  • Rlogin — логин, Rpass — пароль доступа к устройству (eсли они не заданы используется вызов команды без «/protect»)
Читайте также:  Пины ардуино: как назначить на вход-выход, чтение и запись

Пример 1: вызов функции с обращением к PDU через стандартный порт http при выключенном в модуле «защищенном режиме», включение реле №2:[$FuncRODOS10rele Radr=»192.168.1.20″ Rrele=»2″ Rstatus=»on»] Пример 2: вызов функции с обращением к PDU через настроенный порт http 8021 при установленном «защищенном режиме», выключение реле №2[$FuncRODOS10rele Radr=»192.168.1.20″ Rport=»8021″ Rrele=»2″ Rstatus=»off» Rlogin=»login» Rpass=»password»] Ответ функции может быть возвращен в строковую переменную Rodosanswer. Rodosanswer может содержать следующий текст: • «Success! » — в случае успешного обращения и исполнения команды

• «Fault» — в случае ошибочного обращения и неисполнения команды

• «ERROR: rele range mismatch» — в случае указания недопустимого номера реле
в параметре функции Rrele для данной версии устройства

• «ERROR: rele regime set mismatch» — в случае незаданного либо неверно
заданного параметра функции Rstatus («on», «off», «inv»)

• «ERROR: device not responded» — в случае отсутствия ответа от устройства
на пинг

• «ERROR: command ROS » — в случае возникновения ошибки непосредственно
при исполнении URL-команды RouterOS fetch (как правило, при неправильно
указанном номере порта в Rport, неправильно указанных параметрах Rlogine
и/или Rpass)
Вызывать функцию управления реле на PDU можно из любых других Ваших скриптов следующим образом:

  1. Сначала нужно исполнить скрипты, размещающие нужные функции в окружении переменных реппозитория роутера. Это можно сделать однократно, например, при старте роутера из Планировщика RouterOS (/system sсheduler) # однократно запускаем скрипт функции для ее размещения в окружении
    /system script run Func_RODOS10rele;

    # аналогично устанавливаем в окружение функцию «FuncPing»
    # (используется функцией FuncRODOS10rele)
    /system script run Func_Ping;

  2. После того, как функции определены, можно ими пользоваться (в частности вызывать FuncRODOS10rele) В качестве примера вызовем нашу функцию, подав импульс на реле №4 PDU RODOS-10: :global FuncRODOS10rele;
    :local Rodosanswer [$FuncRODOS10rele Radr=»192.168.1.20″ Rport=»8021″ Rrele=»4″ Rstatus=»inv» Rlogin=»login» Rpass=»password»];
    :log info $Rodosanswer;
    Ответ будет возвращен в переменную Rodosanswer и, в данном случае, отображен в логе роутера.

    Готовая библиотека функций для работы с PDU

    Для удобства использования мной была создана библиотека функций для PDU Rodos моделей 8, 9, 10 и 10 исполнения DIN (версия библиотеки 1.0 от 25 декабря 2017 г). Скрипты библиотеки объединены в файл Func_RODOS.rsc, который может быть импортирован в RouterOS следующей командой терминала утилиты WINBOX: /import file= Func_RODOS.

    rsc Процесс импорта может занять от 20 секунд до 1 минуты в зависимости от модели роутера Микротик (его быстродействия). При этом все скрипты, ранее имевшиеся в роутере не затрагиваются, функции и скрипты библиотеки Func_RODOS добавляются к существующим скриптам реппозитория. Библиотека Rodos.rsc версии 1.

    0 содержит следующие скрипты:

    • start_RODOS – запуск этого скрипта устанавливает все функции в Окружение переменных
    • Func_Ping – функция проверки адреса на «пинг»
    • Func_Mail – функция отправки произвольного сообщения на почту администратора роутера
    • Func_RODOS8rele – функция управления реле PDU RODOS-8
    • Func_RODOS8reset – функция сброса («перезагрузки») реле PDU RODOS-8
    • Func_RODOS9rele — … аналогично для указанных моделей …
    • Func_RODOS9reset
    • Func_RODOS10rele
    • Func_RODOS10reset
    • call_example […] – примеры вызовов функций библиотеки
    • Func_RODOS_lib – все функции PDU (кроме Ping и Maйл) в одном файле-скрипте

    После импорта библиотеки Вы можете удалить ненужные функции и скрипты из реппозитория, оставив только функции своей модели PDU и скрипты с функциями FuncMail и FuncPing. В библиотеке, для каждой из поддерживаемых моделей PDU, также присутствуют удобные функции сброса («перезагрузки») (помечены в названиях как «~reset»). Параметры функций перезагрузки аналогичны параметрам функций установки реле, за исключением параметра «Rstatus», который не используется при «перезагрузке» и введенного дополнительного необязательного параметра Rtime, определяющего время в секундах между выключением и включением переключаемого реле (если Rtime не передается функции, по умолчанию используется время 5 секунд). Функции перезагрузки работают следующим образом:

    1. Указанному реле отправляется команда на выключение
    2. Затем производится ожидание Rtime секунд с последующей командой включения. При этом функции перезагрузки обращаются к соответствующим функциям установки реле, которые должны быть определены до вызова первых

    Таким образом, если до вызова функции перезагрузки, определенное реле было включено, оно будет выключено и через заданное время снова включено (а нагрузка, подключенная к нему, «перезагружена»). Над выключенным реле производится аналогичная операция и после работы функции реле становится включенным (то есть, в этом случае функция отрабатывает как функция включения реле). Функции сброса удобно использовать для перезагрузки, подключенного к PDU Rodos «зависшего» сетевого оборудования (точек доступа, роутеров, свичей, различных серверов и т.д…). Исходные коды библиотеки Rodos.rsc (функции и скрипты-примеры обращения к ним) достаточно подробно «прокомментированы», что может пригодиться желающим детально разобраться в работе библиотеки (а возможно и самостоятельно доработать их, либо написать свой вариант).

    В примерах вызовов функций перезагрузки после отработки действия функции реализована отправка сообщений на адрес электронной почты администратора роутера (в настройках переменных скрипта Вы можете указать свой почтовый адрес). При этом скриптами используется почтовая служба RouterOS из /tool e-mail, параметры которой должны быть Вами заранее корректно настроены.

    Планы на будущее

    В последующем библиотека скриптов для PDU Rodos будет расширяться — планируется создание функций для интернет-метеостанции RODOS-16, имеющей «на борту», помимо реле, линии ввода/вывода и датчики температуры / влажности / атмосферного давления.

    Также планируется реализовать логирование работы функций не только в лог роутера и на почту, но и на заданный номер телефона по выбору пользователя (посредством отправки SMS-сообщений через модем роутера).

    Возможно, в процессе применения библиотеки пользователями (и в том числе читателями данного материала) будут выявлены какие-либо ошибки, которые, как правило, неизбежны, при любой разработке. О всех ошибках, замечаниях и пожеланиях прошу сообщать мне для их коррекции.

    Ссылка на описание команды Fetch для роутеров MikroTik

    Ссылка на документацию к используемым PDU Ссылка на библиотеку скриптов-функций для PDU Rodos

    Серков Сергей Владимирович, 26.12.2017 г.

ᐉ USB реле, управляемое через интернет MasterKit MP709 купить в Украине, Киеве с доставкой

  • Технические характеристики:
  • Напряжение питания, В 5 (USB)
  • Ток потребления не более, мА 50
  • Максимальный коммутируемый ток, A
  • 120VAC — 12
  • 240VAC — 10
  • 28VDC — 10
  • Количество каналов управления нагрузкой 1
  • Размеры печатной платы, мм 16×48
  • Комплект поставки
  • Блок реле в сборе 1
  • Инструкция пользователя 1
  • Описание работы устройства и его подключение
  • Принципиальная электрическая схема приведена на рис 2.

Центральная часть устройства – микроконтроллер ATtiny45, работающий на частоте 16.5 МГц. Управление осуществляется с помощью персонального компьютера через USB-порт.

Описание программного обеспечения (ПО)

Для работы с устройством необходимо скачать программу MP709.exe.

Программа может работать в 2-х режимах: локальный и удалённый.

В локальном режиме в левом окне отображаются подключенные устройства MP709. С помощью правой кнопки мыши осуществляется переименование устройства или вывод сведений о нем.

Для удобства работы переименуйте каждое устройство в соответствии с выполняемой задачей, например «RELE_1». Максимальное количество подключённых устройств – 32. В этом же окне можно изменять состояние нагрузки.

Справа находятся пункты меню анализа внешних воздействий на нагрузку.

Установка галочки в поле «файл состояния» позволяет управлять нагрузками через файл «MP709.local.set», формат файла текстовый, формат команды =, например RELE_1=ON, RELE_1=OFF.

Установка галочки в поле «FTP» позволяет управлять нагрузками через файл «MP709.remote.set», хранящийся на FTP-сервере (формируется в удалённом режиме).

Установка галочки в поле «расписание» позволяет управлять нагрузками по расписанию файл расписания — «MP709.local.shd». Формат записи в файле(регистр важен!):

DD.MM.YYYY D HH:MM:SS =

Где DD.MM.YYYY — день, месяц, год, D — день недели (значение от 1 до 7, где 1 — воскресенье, 2 — понедельник, и т. д.), HH:MM:SS — часы, минуты, секунды, NAME — имя реле, ON — включить, OFF – отключить. В полях даты, дня недели и времени допустимо использовать «*», например:

**.**.***** 6 20:**:** RELE_1=ON

означает: каждую субботу в 20:00-22:59:59 RELE_1 включается.

В удалённом режиме в левом окне отображается список устройств MP709. В левом окне можно изменять состояние нагрузки, а в правом отображается дата, время и состояние устройств. В этом режиме формируется файл «MP709.remote.

set», который передаётся на FTP-сервер, затем читается файл «MP709.remote.state», который читается с FTP-сервера и отображается в правом окне. По кнопке «обновить» выполняется передача «MP709.remote.set» и приём «MP709.remote.

state».

  1. Пункт меню «Настройки-Автозапуск» позволяет настраивать автозапуск программы при входе в систему.
  2. Пункт меню «Настройки-Свернуть при запуске» свернуть программу в трей.
  3. Пункт меню «Настройки-Системные сообщения» позволяет настроить показ системных сообщений.
  4. Пункт меню «Настройки-Вести лог действий» настраивает ведение и отображение протокола выполняемых операщий.
  5. Пункт меню «Настройки-Задержка» настраивает задержку между повторениями операций анализа файлов и обращения к FTP-серверу.

Пункт меню «Обновление» становится доступным при наличии новой версии программного обеспечения и позврляет загрузить последнюю версию MP709.exe.

  • Также возможно управление нагрузкой с помощью командной строки:
  • MP709.exe = …
  • Например:
  • MP709.exe RELE_1=ON RELE_2=OFF

Для управления нагрузками через интернет необходимо пройти регистрацию на любом публичном сервере, поддерживающем FTP доступ к файлам, например http://narod.yandex.ru/ и создать персональную страницу. После этого необходимо отредактировать файл MP709.ini, вписав в него свои регистрационные данные, например:

[FTP]

HOSTNAME=ftp.narod.ru

  1. USERNAME=mp709
  2. HOSTDIRNAME=
  3. PASSWORD=пароль
  4. Только после этого будет возможно удалённое управление нагрузками.
  5. Если Вы хотите запустить программу в локальном режиме на нескольких компьютерах, то задайте разные имена файлов в параметре REMOTE_STATE_FILE, например
  6. Компьютер 1:
  7. REMOTE_STATE_FILE=MP709.PC1
  8. Компьютер 2:
  9. REMOTE_STATE_FILE=MP709.PC2
  10. А в параметре REMOTE_LIST_FILES перечислите их через “;”, например:

REMOTE_LIST_FILES=MP709.PC1;MP709.PC2;

  • Не забудьте сохранить ini-файл и перезапустить программу.
  • Внимание:
  • устройство не содержит защитных предохранителей, соблюдайте осторожность при монтаже.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock
detector